Форум программистов CodeGuru
16 Январь 2018, 22:56:46 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.

Войти
Новости:
 
   Начало   Помощь Войти Регистрация  
Страниц: [1]   Вниз
  Печать  
Автор Тема: Ошибка Sybase SQL Anywere 5.5 при соединении в ASP  (Прочитано 17451 раз)
0 Пользователей и 1 Гость смотрят эту тему.
rodion_x52
Новичок
*
Офлайн Офлайн

Сообщений: 2


Просмотр профиля
« : 23 Декабрь 2007, 19:30:19 »

Доброго времени суток. У меня такая проблемма, помогите, если кто знает...

При подключениее к базе данных Sybase SQL Anywere 5.5 в следующем АСП коде
Код:
16 Set oConn = Server.CreateObject ("ADODB.Connection")
17 oConn.ConnectionString = "DSN=mydbase"
18 oConn.Open

Возникает ошибка
Microsoft OLE DB Provider for ODBC Drivers ошибка '80004005'
[Microsoft][Aeniao?a? a?aeaa?ia ODBC] Ioeaea SQLAllocHandle aey a?aeaa?a a SQL_HANDLE_ENV

/reisy.asp, line 18

Установлен сервер IIS, источник данных ODBC mydbase
Причём Delphi с этим источником работает нормально. A ASP нормально работает с источником данных *.MDB, Делфи также нормально работает с *.MDB.
Не могу понять почему АСП не хочет работать с Sybase..
Спасибо кто поможет.
Записан
3V
Администратор
Ветеран
*****
Офлайн Офлайн

Сообщений: 1347



Просмотр профиля WWW
« Ответ #1 : 23 Декабрь 2007, 21:18:01 »

Цитировать
Microsoft OLE DB Provider for ODBC Drivers ошибка '80004005'
[Microsoft][Aeniao?a? a?aeaa?ia ODBC] Ioeaea SQLAllocHandle aey a?aeaa?a a SQL_HANDLE_ENV

Мда... все понятно  Закатывать глаза

Я предположу, что это:

Цитировать
Microsoft OLE DB Provider for ODBC Drivers error '80004005'

[Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified
"Имя источника данных не найдено и не указан драйвер по умолчанию".
Вот что по этому поводу написано в MSDN: http://support.microsoft.com/kb/238971

Советуют сделать так:

Цитировать
1.   Start Registry Editor (Regedt32.exe).
2.   Locate the following key in the registry:
Hkey_Local_Machine\Software\ODBC
3.   On the Security menu, select Permissions.
4.   Select Replace Permission on Existing Subkeys and set the permissions for the Everyone group to full control.
5.   Quit Registry Editor.
То есть надо в реестре для ключа Hkey_Local_Machine\Software\ODBC дать права всем группам на все действия.

Ну и еще там в начале статьи рекомендуют проапдейтить IIS Улыбка


Да, еще вопрос. Там аутентификация нужна для доступа к БД ?
Может надо в ConnectionString еще логин с паролем указывать ?
« Последнее редактирование: 23 Декабрь 2007, 21:20:33 от 3V » Записан

rodion_x52
Новичок
*
Офлайн Офлайн

Сообщений: 2


Просмотр профиля
« Ответ #2 : 23 Декабрь 2007, 22:55:42 »

Нет, тип оштбки маленько другой. Вот его русский вариант

Тип ошибки:
Microsoft OLE DB Provider for ODBC Drivers (0x80004005)
[Microsoft][Диспетчер драйверов ODBC] Ошибка SQLAllocHandle для драйвера в SQL_HANDLE_ENV

Тоесть источник она видит, но может с ним работать..

Ваш способ не помог. В принципе там и так системе и администратором было разрешено всё, врядли может разрешения опытным пользователям чтото могло дать

Аутентификация не нужна, так как прописанна в источнике ODBC

Хочу обратить внимание что прога на делфи соединяется с этим DSN баз проблем. Сама запускае клиет и может выполнять любиые действия.

Записан
3V
Администратор
Ветеран
*****
Офлайн Офлайн

Сообщений: 1347



Просмотр профиля WWW
« Ответ #3 : 23 Декабрь 2007, 23:31:36 »

Имхо, это все-таки из-за проблем с настройками безопасности.
Порылся в гугле. У народа похожие проблемы. Только с ораклом.
Пишут что это из-за того, что клиент оракла требует привилегий "Authenticated User" на домашнюю папку оракла.
Решают путем установки нужных прав на нужную папку.
Цитировать
1. Log on to Windows as a user with Administrator privileges.

2. Launch Windows Explorer from the Start Menu and and navigate to the
ORACLE_HOME folder. This is typically the "Ora92" folder under the
"Oracle" folder (i.e. D:\Oracle\Ora92).

3. Right-click on the ORACLE_HOME folder and choose the "Properties"
option from the drop down list. A "Properties" window should appear.

4. Click on the "Security" tab of the "Properties" window.

5. Click on "Authenticated Users" item in the "Name" list (on Windows
XP the "Name" list is called "Group or user names").

6. Uncheck the "Read and Execute" box in the "Permissions" list under
the "Allow" column (on Windows XP the "Permissions" list is called
"Permissions for Authenticated Users").

7. Re-check the "Read and Execute" box under the "Allow" column (this
is the box you just unchecked).

8. Click the "Advanced" button and in the "Permission Entries" list
make sure you see the "Authenticated Users" listed there with:

Permission = Read & Execute
Apply To = This folder, subfolders and files

If this is NOT the case, edit that line and make sure the "Apply onto"
drop-down box is set to "This folder, subfolders and files". This
should already be set properly but it is important that you verify
this.

9. Click the "Ok" button until you close out all of the security
properties windows. The cursor may present the hour glass for a few
seconds as it applies the permissions you just changed to all
subfolders and files.

10. Reboot your computer to assure that these changes have taken
effect.

Re-execute the application and it should now work.

Может тут что то подобное (раздать права на нужные папки) ?
Под каким пользователем крутится Sybase ?
Записан

Страниц: [1]   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!